ROS6.X 阿里云DDNS及端口映射的正确姿势


脚本用途
将ROS的DDNS更新到托管在Aliyun云解析DNS的域名,方便远程维护ROS。
使用自主注册个性化顶级域名服务。
更新格式
https://www.ros5.com/aliyun/?AccessKeyId=******&AccessKeySecret=******&id=www.ros5.com

脚本示例
#以下是6.x的脚本

    /system scheduler
add interval=3m name=DDNS on-event=":global AccessKeyId     \"AccessKeyId\"\r\
    \n\r\
    \n:global AccessKeySecret \"AccessKeySecret\"\r\
    \n\r\
    \n:global domains \"test.ros5.com\"\r\
    \n\r\
    \n/tool fetch url=(\"https://www.ros5.com/aliyun/\?AccessKeyId=\$AccessKeyId\
    &AccessKeySecret=\$AccessKeySecret&id=\$domains\") mode=https dst-path=ddn\
    s.txt" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:00:00

#以下是5.x的脚本

    /system scheduler
add interval=3m name=DDNS on-event=":global AccessKeyId     \"AccessKeyId\"\r\
    \n\r\
    \n:global AccessKeySecret \"AccessKeySecret\"\r\
    \n\r\
    \n:global domains \"test.ros5.com\"\r\
    \n\r\
    \n/tool fetch url=(\"http://www.ros5.com/aliyun/\?AccessKeyId=\$AccessKeyId\
    &AccessKeySecret=\$AccessKeySecret&id=\$domains\") mode=http dst-path=ddn\
    s.txt" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:00:00

注意事项
1、需要修改脚本内的AccessKey ID和AccessKey Secret及域名再运行!脚本设置的是3分钟更新一次足以满足日常使用。
2、如何获取AccessKey ID和AccessKey Secret? 点右边的链接:https://help.aliyun.com/knowledge_detail/38738.html
3、test.ros5.com:域名,可顶级域名(如ros5.com)或二级域名(如test.ros5.com),如果二级域名不存在系统则会自动创建,顶级域名则会修改@名称的A记录值!
4、脚本执行后会在ros文件里生成一个ddns.txt,更好的调试脚本,发现错误!如果没更新之类的可以先下载查看该文件内容。
5、多线情况下,接口会自动选择DDNS线路!
6、如有疑问或想自主搭建及定制DDNS更新服务请加QQ:962000293!
7、本网站服务器托管在腾讯云上,如遇打开缓慢或无法打开请联系阿里的马哥。
8、捐赠一下服务器费用呗?十块一块都是爱!

以上原文转自:https://www.ros5.com/851.html
食用方法 复制对应自己版本的脚本 直接在ROS WINBOX控制台里 new terminal 里粘贴并回车运行后 在进入/system scheduler 双击DDNS 修改对应的 AccessKey ID AccessKey Secret 以及domains 本人已测试正常使用

关于端口映射,百度资料里有很多误区。6.X版本和我以前接触的2.X 3.X 5.X端口映射方法稍有不同之处就是在EXTRA下dst address type 一定要选择local 如果不选择 会导致内网所有电脑网页无法打开 心累中
案例代码

/ip f n add chain=dstnat protocol=tcp dst-port=80 dst-address-type=local \

action=dst-nat to-addresses=内网的服务IP to-ports=80


文章作者: 因特吧
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 因特吧 !
评论
 上一篇
WINDOWS系统下恢复群晖分区下的文件 WINDOWS系统下恢复群晖分区下的文件
玩群晖也有几年了,从万由的J1900时代就搞了台NAS。当时天天泡论坛看大家都是讲群晖,所以回来也毫不犹豫的刷的群晖。发这个帖子不是为了讲故事。起因也很简单。就是因为我把机器刷回了万由系统,所幸的是我保留了放照片的盘。想挂上去读取的时候发现
2020-02-23
下一篇 
openwrt+阿里云DDNS搭配自己的黑群晖 openwrt+阿里云DDNS搭配自己的黑群晖
本文出自:https://hegu.app/archives/221所谓阿里云DDNS其实并非真正的DDNS服务,而是通过阿里云提供的API加上自己的软路由或者openwrt或其他智能路由实现自动修改DNS记录的功能。因此,使用该方法实现D
2020-02-23